Ello Scheduled Maintenance
Incident Report for Ello
Resolved
And we are back up!
Posted 9 months ago. Apr 02, 2018 - 22:40 EDT
Identified
Ello will be down for scheduled maintenance Monday April 2 at 10PM EST for up to 60 minutes.
Posted 9 months ago. Apr 02, 2018 - 21:51 EDT